CastleVille

CastleVille is the only game where you create your own Happy Ending! Make your Kingdom the fairest of them all. Play now!

CastleVille 1-Click Bonuses!

Tired of sifting through the feeds and collecting the bonuses?

Get Game Feed!

 via CastleVille

 via CastleVille

 via CastleVille

 

Grab Bonuses!

Tick Bonus Clicked!

Tick Bonus Clicked!

Tick Bonus Clicked!

Tick Bonus Clicked!

Tick Bonus Clicked!

Tick Bonus Clicked!

Tick Bonus Clicked!

Tick Bonus Clicked!

 
Picture?type=square

Question-whiteACTIVATE MYRICKS FLASK?

Please_share
by Sue Allen - May 08, 2013 Star_s731 views

i still cant activate my myricks flask ..its been 5 weeks now and still no help.how can you banish something you cant see in your kingdom?NO DRAGON

Replies (10)

Sort by: Newest · Oldest · Likes
12-em-plus add reply
Picture?type=square

Sorry if this is not the right place to post this, but unable to find any posts relating to this problem.
I am having a problem with this quest as well....
Extinguish 2 Gloom Flames (click on burning buildings to use Mystic Wind) I have no burning buildings so what am I supposed to do? have been stuck on 3 for ages now.

Picture?type=square

Did anyone ever get a resolution to this?

I'm having the same problem - I can't activate the flask OR summon a dragon (it tells me I already have a dragon in my kingdom, and I don't)

I filed a support ticket, but (surprise, surprise) never received a reply.

Picture?type=square

J'ai également le même problème depuis plusieurs semaines. Si j'appelle un dragon on me dit qu'il y en a déjà un et si le clique sur le chaudron rien ne se passe.

Picture?type=square

same problems game is unplayble ...crap developers..greed

Picture?type=square

I spoke with a Zynga Rep and they are working on this issue. Also, if you are having problems with the matching mushrooms game freezing, they are working on this too. Thanks, Nicole.

Picture?type=square

I have all the ingredients to activate that flask and have tried numerous times. It says it activates but it really doesn't. This has been going on for the same two weeks everyone else talked about. That can't be a coincidence. The poor dragon is just lurking about looking very gloomy now. I will keep trying periodically.

Picture?type=square

Have you tried using the gloom dragon potion to call up a gloom dragon? It can be crafted in your beastie laboratory. Before Myricks flask can be activated you have to have 2 dragon sparks from putting out gloom dragon flames, along with other ingredients that should be shown when you click the flask.

Picture?type=square

it says on mine i have an active dragon in kingdom..... it isnt there... cant finish the TOM quest without finding that invisible dragon..... go figure

Picture?type=square

I have tried off and on for over 2 weeks to activate Myricks flask as well. Still nothing. I have had a Gloom Dragon flying around my kingdom since I put out my first gloom fire. Still no quest or anything else to do with it, it just is hanging out? Go figure!! Let me know if you figure out how to get the flask activated. I will just keep trying every now and then.

Picture?type=square

I'm having the same problem...and I don't see a gloom dragon either!

Showing 10 of 10 comments