Ravenskye City

Join a band of intrepid explorers on an expedition to help restore Ravenskye City to its former glory!

Need more Ravenskye City Friends?

Let's connect and help each other progress!

Friends

Link Exchanges!

Members are exchanging the following items right now! Go exchange yours too!

Picture?type=square

Question-whiteTrouble loading Ravenskye City

Please_share
by Carolyn W-j - Nov 02, 2011 Star_s506 views

For a few days now the game doesn't finish loading. I have tried opening thru fb, mozilla, ie and chrome. Same thing. Cleaned cache, tried it at the www. address - refresh gazillions of times - all for the same things. I am running flashplayer 11 - but was using the 10.3 when it started happening. Any help would be appreciated.

Replies (6)

Sort by: Newest · Oldest · Likes
12-em-plus add reply
Picture?type=square

give up it's them not you. From what they told me the engineers are "working on it"...LOL I did everything short of reinstalling my entire system LOL....the funny thing is that some functions work on different computers in my house. The only difference is the settings & operating system. Some use Windows & others Vista. So, I can't figure it out nor can my DH who's an IT engineer himself. We just have to wait it out or go play Ravenwood Fair until it's fixed. Or, we could go play the other popular games like Castleville, Hidden Chronicles, Slingo, etc. BUT, I don't want to do that so I'm just doing what I can and using the gift exchange for everything. It's taking forever. :(

Picture?type=square

same here it's annoying but add me lol

Picture?type=square

Same here...3 days now, load bar gets to the end and then ...nothing....tried all the tips, different browsers/emptying cache etc...can accept and send gifts but can't play. I was wondering if flash player might be the problem sice it upgraded to 11....very sad :-(

Picture?type=square

I haven't been able to fix it yet at all. Every day I try to log on. The bar loads all the way across and I can accept and send gifts but the game itself won't load. Clicking the "play" button doesn't help either. If anyone has the answer I'd love to know it!

Picture?type=square

I am having the same problem and it just started today. I was able to get on it this morning but then when I tried to load it this afternoon it would not finish loading. If you have fixed yours can you please help me out. Thanks!

Showing 6 of 6 comments